+1
0
-1

Parse error while building the environment - VectorCAST/C++ 6.4n

Hi, I am trying to build environment for c++ file. The code is based on C++14 standard and linux environment. And also, code is based on Qt environment.

when I tried to build the...

Posting in: 

6 Answers:

+1
0
-1

Hello,

Could you add ...

+1
0
-1

Hi Brian,

Thanks for your reply.

when I updated the Parse flags as you mentioned, now I started getting parse errors for 64bit related functions as shown below:

"/usr/lib...

+1
0
-1

Hello Suresh,

I think I may have specified too many parser arguments. Could you remove ...

+1
0
-1

Hi Brian,

Thanks for your reply.

Now, I started getting different error:
"/usr/include/c++/4.9/bits/basic_string.h", line 3151: error: invalid second
...

+1
0
-1

I've looked through our knowledge base. Best guess is 6.4n is too old to deal with this. There are reports that 6.4t works ok.

I would recommend you upgrade to a new version of VC. Let's...

+1
0
-1

apart from the errors mentioned above, there are few more errors:
"/usr/lib/gcc/x86_64-linux-gnu/4.9/include/ia32intrin.h", line 246: error:
identifier "...